Bewertung: 4 / 5

Stern aktivStern aktivStern aktivStern aktivStern inaktiv
 

Problembeschreibung MTP-USB-Geräte Verbindung nicht möglich

english version of the article

Sie wollen Daten austauschen/synchronisieren zwischen Ihrem Windows-PC und Ihrem Smartphone mit Android und müssen feststellen, dass der Verbindungsaufbau nicht möglich ist, weil der USB-Treiber offensichtlich nicht korrekt installiert wird.

Prinzipiell ist es schon so, Smartphone per USB an den Rechner anschließen und es werden sofort, wenn noch nicht erfolgt, die Gerätetreiber geladen und die Massenspeicher des Smartphones auf dem Rechner geladen, bzw. als Massenspeicher bereitgestellt.

Auf meinem Samsung Galaxy Note GT-N7100 hatte ich konkret den Fall, dass ich bereits mehrfach das Gerät erfolgreich am Rechner anschließen konnte und plötzlich von Heute auf Morgen dies nicht mehr funktionierte. In Foren gab es diverse Hinweise, wie Treiber neu installieren, Kabel tauschen und USB-Buchse reinigen, Handy komplett ausschalten und nach 3 Minuten wieder booten, den USB-Debugmodus aktivieren etc. Keiner dieser Tipps half.



Dann ging ich auf die Suche im Windows Gerätemanager und beobachtete die Fehlermeldungen bei der Treiberinstallation.

 

Hier mal ein paar diesbezüglich relevante Screenshot, die Sie bei sich ggf. auf feststellen werden:

Diese Meldung erhalten Sie wenn der Treiber z.B. nach vorheriger Deinstallation oder bei kompl. Neueinrichtung/Erstanschluss des Gerätes am PC automatisch geladen und installiert wird. Hier ist das Laden des MTP-Treiber noch im Prozess.

Der Treiber wurde geladen, aber die Nutzung des Gerätes ist trotzdem nicht möglich. Diese Meldung quittiert Ihnen das böse Ergebnis.

Wenn Sie z.B. im Gerätemanager sich die Eigenschaften Ihres Android-Handy anschauen, werden Sie hier immer mal beim MTP-USB-Gerät das gelbe Dreieck mit Ausrufezeichen sehen, was Ihnen sagt, dass die Massenspeicherfunktion Ihres Handy nicht zur Verfügung steht.

Wie hier zu sehen, ebenfalls im Gerätemanager.

 

Lösung des Problem

Zunächst mal noch eine Information vorweg, die dann zum Verständnis nicht ganz unwichtig ist. Was ist das MTP überhaupt. Das ist ein Protokoll, welches unter Windows oder auch Mac-OS die Übertragung von Mediendaten mit Android ermöglicht. Dieser Dienst stellt Ihnen die Daten der Massenspeicher Ihres Android-Handys auf dem PC als Laufwerk mit Verzeichnissestrukturen da. Neben diesem Protokoll gibt es als Alternative auch noch PTP, welches speziell dafür entwickelt wurde, Fotos zwischen Kameras und dem PC zu übertragen. Android bietet auch dieses Protokoll an, dann aber meldet sich Ihr Handy auf dem PC nicht als Massenspeicher und den evlt. Zusatzfunktionen (z.B. Accesspoint-Modem etc.) sondern eben als Kamera an. Für bestimmte Einsatzzwecke hat das Vorteile, die hier aber nicht relevant sein sollen.

Zunächst sollten Sie überprüfen, ob Sie überhaupt sauberen physikalischen Connect zu Ihrem Androidhandy haben. Das sehen Sie i.d.R. daran, dass am Handy das USB-Symbol in der Task-Leiste oben angezeigt werden sollte. Beim Verbindungsaufbau hören Sie am Smartphone auch ein Piep-Geräusch. Wenn Sie die Taskleiste auf dem Handy aufziehen, sollte ein Meldungstext in der Benachrichtigungsliste mit einem USB-Symbol stehen mit in etwa diesem Wortlaut: "Als Mediengerät verbunden". Das sagt schon, dass als Mediengerät verbunden wurde. Wenn "als Kamera" da steht, dann diese Meldung anklicken und in der USB-Einstellung von PTP auf MTP umschalten.

Ebenfalls setzen wir hier schon voraus, dass Sie die Maßnahmen zur Installation oder Aktualisierung der Treiber vorgenommen haben - eigentlich so wie es automatisch passiert.



Die Lösung ist am Ende einfach und auch etwas unerklärbar - aber wen interessiert der Grund, wenn die Lösung funktioniert.

  1. Ziehen Sie die Taskleiste auf (kleines Dreieck in der Symbolleiste im Bereich, wo i.d.R. auch die Lautstärkeregelungen, sowie Sprach- und Datumseinstellungen sind)
  2. In der nun sichbaren Liste der offene Anwendungen finden Sie auch eines mit dem USB-Icon benannte als "Als Mediengerät verbunden"
  3. Klicken Sie auf diesen Listeneintrag und Sie gelangen auf einen Konfigurationsscreen für weitere USB-Einstellungen "USB-PC-Verbindung".
  4. Jetzt das Verrückte: "Mediengerät MTP" ist üblicherweise und wie zu erwarten aktiv gekennzeichnet. Wählen Sie statt dessen "Kamera (PTP)" und beobachten die Reaktionen auf Ihrem PC. Er wird jetzt dieses "neue" USB initialisieren, i.d.R. erfolgreich und als Kamera verfügbar machen (s. dazu immer das "Geräte und Drucker"-Fenster).
  5. Jetzt aktivieren wir an gleicher Stelle einfach wieder "Mediengerät (MTP)" und beobachten wieder unseren Gerätemanager. Das Handy verschwindet als Kamera und erscheint nun nach dadurch erneut angeschobener Initialisierung als "Tragbares Medienwiedergabegeräte" in Ihrer Laufwerksliste und als Ihr benanntes Handy in der Liste der "Geräte und Drucker". Wenn Sie Kies entspr. konfiguriert haben, wird auch Kies automatisch geöffnet und der Dialog "Automatische Wiedergabe" von Windows wird eingeblendet.

 

Wenn Ihnen dieser Beitrag geholfen und viel Zeit gespart hat, zeigen Sie sich erkenntlich: Über einen Klick auf Google+1 oder Rückmeldungen freue ich mich. Zeigen Sie mir, dass sich die Mühe für die Beitragerstellung gelohnt hat. Schenken Sie auch den Produktwerbungen Ihre Beachtung, denn damit wird mein Aufwand für diese Beiträge refinanziert.

english version of the article

Kommentare (73)

This comment was minimized by the moderator on the site

Hallo nochmal ,

einen Teilerfolg habe ich hier auch zu vermelden , unter XP habe ichs geschafft das Odys Rapid10 Tablet mit Android 5.1. und MypPoneExplorer endlich per Windows nutzbqar zu machen .

Dennoch ist es umstänlicher als allgemein Treiber für Windows nachzurüsten da hier Filekopie angesagt ist und selbst dann nicht mal ne garantie dafür gibt das es funktioniert , den die fürs Trekstor Breeze 7 Quad funzen anscheinend nicht , und mit den ADB -, MTP Treiber ausm Netz gabs dahingehend Probleme weil Windwos meckert das in der Deinstallationsroutine fehler sind und die installation NICHT zum abschluss kam.
Per Linux Live ist alles easy da wird z.B. Rapid direkt erkannt und mit Karten SIM wie SD direkt zum mounten angeboten. Alleine dieser hickhack USB-Debugging ja oder nein , aber um 5:00 Nacht hatte ichs dann endlich.

Ro.Schä.66
This comment was minimized by the moderator on the site

Manchmal sieht mann den Wald vor lauter Bäumen nicht, ich erkläre mich hiermit zum Fachidioten.........
;);)
So simpel.......

Danke für den Tipp, hast nen Orden verdient !!!!

Explosionselektriker
This comment was minimized by the moderator on the site

Bei mir erscheint in der Statusleiste kein Hinweis, von daher ist die Anleitung Mist. Man muss doch auch über die Einstellungen irgendwie zu dem Menü kommen, in dem ich "Als Mediengerät bla Käse" auswählen kann?

Hallo
This comment was minimized by the moderator on the site

Mehrere Wochen für mein OnePlus One gesucht, dessen interner Speicher plötzlich (Systemupdate??) plötzlich im Explorer und bei MobileGo nicht mehr angezeigt wurde. Dank dieser Lösung erfolgt jetzt wieder die Erkennung im Explorer. Weiterhin aber nicht bei MobileGo.
Trotzdem ganz herlichen Dank für Deine Anregung und Lösung.
Frage: Muss ich bei jeder Neuverbindung über das Menu des Handys gehen oder gibt es auch eine Möglichkeit, die Auswahl "Datenübertragung" permanent wieder zu benutzen?

Peter
This comment was minimized by the moderator on the site

Hey.
Iwie wird bei mir nur die Kamera erkannt...wenn ich dann auf MTP gehe, wird nur angezeigt das der Treiber immer noch nicht geht.
Ist das normal oder habe ich evtl. was falsch gemacht?

Kabandha
This comment was minimized by the moderator on the site

Einfach auf diese Link anklicken https://www.microsoft.com/en-us/download/details.aspx?id=19153 und Media Transfer Protocol Porting Kit (MTP)
Herunterladen und installieren danach das Handy an schlissen und Abrakadabra es funktioniert!!!!!

Leonardo Dinoi
This comment was minimized by the moderator on the site

Ganz einfach auf diese Link https://www.microsoft.com/en-us/download/details.aspx?id=19153 und die Media Transfer Protocol Porting Kit
(MTP) herunterladen und installieren danach Handy an schlissen Umbenanntes Gerät Treiber Manuel installieren MTP aus der liste anklicken und das war

Leonardo Dinoi
This comment was minimized by the moderator on the site

b]Ganz einfach auf diese Link https://www.microsoft.com/en-us/download/details.aspx?id=19153 und die Media Transfer Protocol Porting Kit
(MTP) herunterladen und installieren danach Handy an schlissen Umbenanntes Gerät Treiber Manuel installieren MTP aus der liste anklicken und das war

Leonardo Dinoi
This comment was minimized by the moderator on the site

Vielen Dank für diese Tips. Bei mir (Acer Z630S, Android 5.1, Windows 8.1) hat letztendlich das Umschalten von MTP auf PTP und wieder zurück (am Android) geholfen. Die Symptome waren wie folgt: nach Erstinstallation des MTP-Treibers im Windows konnte ich auf den Telefonspeicher zugreifen. Nach dem nächten Windowsstart dann nicht mehr. Das Gerät wurde im Explorer angezeigt aber ohne Inhalte.

Andreas M.
This comment was minimized by the moderator on the site

Nach dem ganzen Programm von wirkungslosen Maßnahmen mit Kies, manueller Installation vom Treiber usw. war die hier beschriebene Lösung meine einzige Rettung! Sehr schöne und verständliche Problem- und Lösung-Beschreibung.

Danke!

Veronika
This comment was minimized by the moderator on the site

Bei mir hat es funktioniert, in dem ich mir diesen https://www.netzwelt.de/download/18612-samsung-android-usb-driver-for-windows.html Treiber heruntergeladen und installiert habe.
Handy und PC mit dem USB Kabel verbinden und alles funktioniert.

Hells Bier
This comment was minimized by the moderator on the site

Stell das Handy auf Massenspeicher ein, dann geh in den Gerätemanager (PC) und rechtsklicke auf MTP-USB-Gerät. Anschließend "Treiber aktualisieren". Hier ist aber wichtig, dass du es nicht automatisch zulässt, sondern manuell machst.
Danach wählst du aus den Optionen an Geräten "Massenspeichergerät" aus und schwupps sollte er dein Handy (wieder) als Massenspeicher anerkennen.

ups
This comment was minimized by the moderator on the site

Vielen Dank für den phantastischen Tipp. Seit Monaten ärgerte mich dieses Problem. Nun geht wieder alles!

R. B.
This comment was minimized by the moderator on the site

Hallo, bei mir war das Problem, dass ich mit einem Start-Manager der System-App "MTP-Anwendung" das automatische Starten verboten hatte. Dann kam von Windows immer bei Treiberinstallation der Gerätefehler 10.

T.K.
This comment was minimized by the moderator on the site

Diese Information ist genial. Herzlichen Dank. Super!!!

Peter
This comment was minimized by the moderator on the site

Besten Dank. Genial die Information. Super!!!

Peter
This comment was minimized by the moderator on the site

Hi ihr lieben! Leider hat der hier beschriebene Trick bei mir nicht funktioniert :o:o:o
Ich habe das Problem das ich den MTP Treiber im Gerätemanager sehen kann sobald Cam oder Handy angesteckt wird mit einem Ausruffezeichen und dem Hinweiß das das Gerät nicht gestartet werden kann, nach dem manuellen Entfernen und neusuchen jedoch Iniziert er ganz normal das MTP Gerät! Jedoch nur bis zum nägsten Neustart. Einsetzen tuhe ich Windows 7 Pro x64. Hat da wer nen tipp? Wenn ja würde ich mich sehr freuen.

Kommentar zuletzt bearbeitet am vor 2 Jahren von Steffen Kraft Alexa Weber
This comment was minimized by the moderator on the site

das funktioniert nicht immer.
man kann auch im gerätemanager unter den nicht erkannten geräten (Pfad in win81: dieser pc, verwalten, gerätemanager, andere geräte) nachschauen. wenn mtp nicht funkioniert ( anzeige unter mobile geräete im gerätemanager) findet man evtl. ein unbekanntes gerät hier, doppelklick und suchen unter installierte treiber, aussuchen zb mtb-usb-gerät. hat bei mir funkioniert.

Boris
This comment was minimized by the moderator on the site

hat perfekt geklappt, vielen Dank

d
This comment was minimized by the moderator on the site

Taskleiste aufziehen wird die am Handy gemeint sein...von oben runter ziehen. so wars jedenfalls bei meinem note 3. Und da kommt man dann auch in dieses Menü. Gewechselt auf Kamera....wurde initialisiert...und dann wieder gewechselt....Klasse Tip. Funktioniert wunderbar. Stundenlanges ärgern und probieren von 12 verschiedenen USB Kabeln und keine Lösung.....und hier in 15 Sekunden Problem gelöst. VIELEN VIELEN DANK.

Basti
This comment was minimized by the moderator on the site

Mein Problem: Ladevorgang in Ordnung aber langsam
Verbindung Android zu Win auf verschiedenen Versionen und PCs über USB nicht möglich.

Meine Lösung:
Smartphone aufmachen
Microusb port gründlich sauber machen
Schmutz mit Nadel und Papierstreifen vorsichtig entfernen. Optional: leichte Pressluft + dünnen Film Kontaktspray/Kriechöl auftragen + Überschüsse fest wegpusten/ auftupfen mit Taschentuch.

Wieder alles super!
Habe aber auch zuvor stundenlang mit driver hardreset & co herum probiert, dabei hatte ich nur schmutzige Hosentaschen in die ich das Smartphone gesteckt hatte und somit nachhaltig den microusb port verstopft. Komischerweise ließ sich das Smartphone aber immer laden....

Hoff es hilft LG David

David
This comment was minimized by the moderator on the site

Super Tipp...besten Dank !

Monatelang erfolglos rumprobiert und hier kam die Lösung ;O)
Hier noch Mal in anderen Worten für die neueren Android-Versionen:

Handy am Rechner anschließen, dann die Taskleiste (Notification Bar) am Handy runterziehen,
dort unten klicken auf „USB zur Dateiübertragung“
Da ist automatisch der Punkt „Dateien übertragen“ ausgewählt,
dann „Bilder übertragen“ auswählen – kurz warten
und dann wieder „Dateien übertragen“ auswählen…

...alles funktioniert ;O)

Viele Grüße, Thomas

Thomas
This comment was minimized by the moderator on the site

N'Abend,

also ich hatte genau das beschriebene Phänomen: Vor einem Monat funktionierte es sowohl mein Smartphone (Galaxy S 4 Mini) als auch mein Tablet (Galaxy Tab 4) an jedem Rechner (Win XP PC, Win 7 PC, Win 7 Notebook) anzuschließen und per Windows Explorer anzusprechen.

Seit gestern plötzlich Nada! Kein Android Gerät an keinem Rechner mit beliebigen Kabeln etc.!

Das Problem: Ein physischer Connect funktioniert soweit, dass der Akku lädt! Aber KEINE Reaktion in welchem Modus ich das Gerät verbinden will und auch KEIN USB-Symbol an keinem der Android-Geräte mehr. Als hätte Google weltweit diese Funktion einfach abgeschalten .. skuril!

Aber nicht wert Lebenszeit für diesen Dreck zu verschwenden. Mist ist Mist und bleibt Mist.

Habe die Ehre

Simon
This comment was minimized by the moderator on the site

hilfe
ich bin einfach nur ne Frau....
mein j 5 verbindet sich nicht mehr mit dem pc und ich weiss einfach nicht was zu tun...
wenn ich es verbinde hör ich den piep und es lädt.... aber ich seh keinerlei verbindung zum pc ... im pc nicht und am handy nicht in den entwickleroptionen
hab ich das geändert mit dem mtp aber nix
es scheint mir seit dem update dass hier alles konfus ist
bin verzweifelt
kann mir jemand helfen???
danke schön

Judith
This comment was minimized by the moderator on the site

Ich gehe davon aus, dass Du dich am Handy eingeloggt hast.
Als nächstes würde ich mal das USB-Kabel ersetzen/untersuchen. Den Fall hatte ich auch schon. Beim Anstöpseln am PC meldet dieser zwar ein Plong, aber das Handy erscheint nicht in der Laufwerkliste. Dann hatte ich mir da Kabel angeschaut, und festgestellt, dass es nahe des einen Steckers arg verformt war und folglich ein Kabelbruch zu vermuten ist. Also ersetzt und siehe da, schon war das Handy als Laufwerk wieder da.
Wenn's das nicht ist, oder ausgeschlossen wurde, müsste man weitersehen. Wobei alle sonstigen Gründe sehr umfangreich wären ferndiagnostisch kaum zu lösen. Gibts noch ein anderes Handy im Haushalt? Dann das mal an den PC hängen. Damit kann man, je nach Erfolg, schon mal einkreisen, ob's am Handy oder am PC liegt und dort entsprechend weiter analysieren.

mD.SK
This comment was minimized by the moderator on the site

Nachdem ich das Problem auch hatte und ich nach 2std suchen es endlich gepackt habe will ich meine Erfahrungen hier kund tun.

Nachdem ich 2std gesucht hab wie ich den Treiber und Updates Installiere und auch diese Anleitung versucht hatte und trotzdem erfolglos blieb wurde ich mit Erfolg belohnt. was hab ich gemacht.

Ich bin in der glücklichen Lage zig USB Leitungen mein eigen zu nennen, die ich auch alle getestet habe, ist mir aufgefallen das das die MTP Treiber mal installiert wurden mal nicht und ein Datensichern ab und zu abgebrochen ist aus mir unerklärlichen Grund.

Welche Leitung hatte am besten Funktioniert. Samsungs Original Leitung (die ich nicht so gerne verwende da der Schirm an der Knickstelle schon ramponiert ist)
Hab auch eine Sehr kurze Leitung getestet, nicht funktioniert.
Eine Noname usb-Leitung damit nicht zufriedenstellend es wurde alles erkannt und instaliert nur MTP wieder nicht.

Da ich jetzt herausgefunden hatte das es etwas mit der Leitung zu tun hatte hab ich mir gedacht wieso es immer noch nicht zufriedenstellend funktioniert, da ist mir aufgefallen das ich vom Big Tower den USB vorne benutze was ja auch nur eine Verlängerung ist auf das Bord (HUB).
Also hab ich den USB direkt auf dem Motherboard verwendet und siehe da alles Funktioniert wie es soll.

Somit ist mein Erkenntnis es lag an der Leitungslänge verwendeten Leitung und dem verwendeten Eingang am PC

Wie das jetzt erklärt werden kann da muss sich jemand anderes mit befassen.
Ich hoffe es hilft jemanden weiter.

EDragon
This comment was minimized by the moderator on the site

Nachdem ich das Problem auch hatte und ich nach 2std suchen es endlich gepackt habe will ich meine Erfahrungen hier kund tun.

Nachdem ich 2std gesucht hab wie ich den Treiber und Updates Installiere und auch diese Anleitung versucht hatte und trotzdem erfolglos blieb wurde ich mit Erfolg belohnt. was hab ich gemacht.

Ich bin in der glücklichen Lage zig USB Leitungen mein eigen zu nennen, die ich auch alle getestet habe, ist mir aufgefallen das das die MTP Treiber mal installiert wurden mal nicht und ein Datensichern ab und zu abgebrochen ist aus mir unerklärlichen Grund.

Welche Leitung hatte am besten Funktioniert. Samsungs Original Leitung (die ich nicht so gerne verwende da der Schirm an der Knickstelle schon ramponiert ist)
Hab auch eine Sehr kurze Leitung getestet, nicht funktioniert.
Eine Noname usb-Leitung damit nicht zufriedenstellend es wurde alles erkannt und instaliert nur MTP wieder nicht.

Da ich jetzt herausgefunden hatte das es etwas mit der Leitung zu tun hatte hab ich mir gedacht wieso es immer noch nicht zufriedenstellend funktioniert, da ist mir aufgefallen das ich vom Big Tower den USB vorne benutze was ja auch nur eine Verlängerung ist auf das Bord (HUB).
Also hab ich den USB direkt auf dem Motherboard verwendet und siehe da alles Funktioniert wie es soll.

Somit ist mein Erkenntnis es lag an der Leitungslänge verwendeten Leitung und dem verwendeten Eingang am PC

Wie das jetzt erklärt werden kann da muss sich jemand anderes mit befassen.
Ich hoffe es hilft jemanden weiter.

Kommentar zuletzt bearbeitet am vor 1 Jahr von Steffen Kraft EDragon
This comment was minimized by the moderator on the site

Hallo EDragon,
vielen Dank für Deinen Post und die Mitteilung Deiner gemachten Erfahrungen. Evtl. können ja andere diese Erfahrung untermauern oder widerlegen. Ich hatte bei meinen Versuchen eher nicht den Eindruck, dass es mit den Kabeln zusammenhängen würde - aber wer will das schon ausschließen. Jedenfalls ist es für diejenigen, die sonst zu keinem Erfolg gelangt sind, eine weitere Option die auszuprobieren wären.

Allerdings ist der Hinweis mit dem internen Anschluss nicht ganz abwägig. Aber das könnte eher mit dem USB-Typ zusammenhängen. Viele Rechner haben heute ja diverse USB-Standards an Bord. Von meinem weiss ich, dass dieser Sowohl USB2 als auch die neueren USB3-Ports bereitstellt. Meist unterschiedlich farbig gekennzeichnet (rot/blau). Lt. meiner Board-Beschreibung soll es auch einen USB-Port geben, der speziell für Handys gemacht ist. Dieser bietet zum einen eine Schnelllade-Funktion an und ist zum Anderen auch stromführend wenn der Rechner eigentlich aus ist (nicht der Powerknopf am Netzteil). Natürlich werden diese unterschiedlichen USB-Ports unterschiedliche Treiber brauchen, die wiederum unterschiedlich auf angeschlossene Geräte reagieren könnten. Hiermit sollte also jeder bei seinen Experimenten rechnen und natürlich alle Ports ausprobieren.

Bei Dir wäre es also mal interessant herauszubekommen, welcher USB-Typ am Board genutzt wurde und welcher vorne durchgeschliffen wurde.

Kommentar zuletzt bearbeitet am vor 1 Jahr von Steffen Kraft Steffen Kraft
Bisher wurden hier noch keine Kommentare veröffentlicht

Einen Kommentar verfassen

  1. Kommentar als Gast veröffentlichen. Registriere Dich oder melde Dich zu Deinem Benutzerkonto an.
0 Zeichen
Anhänge (0 / 3)
Deinen Standort teilen